error when i configure glib for qemu with mingw

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

error when i configure glib for qemu with mingw

marwahamza63
This post has NOT been accepted by the mailing list yet.
hello
i downloaded glib-2.26.1 , then in /c/msys/glib-2.26.1 i run
export LIBFFI_CFLAGS='-I /c/mingw/lib/libffi-3.0.13/include'
export LIBFFI_LIBS=-lffi
export lt_cv_deplibs_check_method="pass_all"
export CFLAGS="-O0 -g -pipe -Wall -mms-bitfields -mthreads"
export CPPFLAGS="-DG_ATOMIC_OP_USE_GCC_BUILTINS=1"
configure -prefix=/c/mingw-builds/mingw64 -with-pcre=internal -disable-static -disable-gtk-doc -enable-silent-rules -build=x86_64-w64-mingw32
i got an error about libintl.h and i change libintl path in configure file but i got an another error 
checking for ngettext in libc ... no
checking for bindtextdomainn in -lintl... no
checking if -liconv is needed to use gettext...
checking for ngettext in -lintl... no
configure:error:
*** you must have either have gettext support in your c library, or use the *** GNU getext library. <http://www.gnu.org/software/gettext/gettext.html

but i have installed gettext package and compiled it succesfully 
./configure --prefix=/c/mingw --enable-threads=win32 --enable-relocatable --build=x86_64-w64-mingw32
make
make install
i'm using msys and mingw64 gcc 4.8.2
thanks
Loading...