configure error with vim72

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

configure error with vim72

Sun, Xiuxin

HI ,

When I want to compile the latest vim, get following error in msys :

-------------
no terminal library found
checking for tgetent()... configure: error: NOT FOUND!
      You need to install a terminal library; for example ncurses.
      Or specify the name of the library with --with-tlib.
-------------

I think all based msys compile pkgs from MingW website are copyed,
please sugguest what I can do.

thanks,
sun

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
MinGW-users mailing list
[hidden email]

You may change your MinGW Account Options or unsubscribe at:
https://lists.sourceforge.net/lists/listinfo/mingw-users
Reply | Threaded
Open this post in threaded view
|

Re: configure error with vim72

JonY-2
On 11/11/2008 17:39, Sun, Xiuxin wrote:

> HI ,
>
> When I want to compile the latest vim, get following error in msys :
>
> -------------
> no terminal library found
> checking for tgetent()... configure: error: NOT FOUND!
>        You need to install a terminal library; for example ncurses.
>        Or specify the name of the library with --with-tlib.
> -------------
>
> I think all based msys compile pkgs from MingW website are copyed,
> please sugguest what I can do.
>
> thanks,
> sun
>

Hi, have you tried PDCurses?

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
MinGW-users mailing list
[hidden email]

You may change your MinGW Account Options or unsubscribe at:
https://lists.sourceforge.net/lists/listinfo/mingw-users
Reply | Threaded
Open this post in threaded view
|

Re: configure error with vim72

Sun, Xiuxin

Yeser, actually there is another error and I don't know how to get also.
------------
checking for sys/ipc.h... no
configure: error: Cannot find required header file sys/ipc.h; PDCurses cannot be configured
------------

-----Original Message-----
From: JonY [mailto:[hidden email]]
Sent: 2008年11月11日 17:53
To: MinGW Users List
Subject: Re: [Mingw-users] configure error with vim72

On 11/11/2008 17:39, Sun, Xiuxin wrote:

> HI ,
>
> When I want to compile the latest vim, get following error in msys :
>
> -------------
> no terminal library found
> checking for tgetent()... configure: error: NOT FOUND!
>        You need to install a terminal library; for example ncurses.
>        Or specify the name of the library with --with-tlib.
> -------------
>
> I think all based msys compile pkgs from MingW website are copyed,
> please sugguest what I can do.
>
> thanks,
> sun
>

Hi, have you tried PDCurses?

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge Build the coolest Linux based applications with Moblin SDK & win great prizes Grand prize is a trip for two to an Open Source event anywhere in the world http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
MinGW-users mailing list
[hidden email]

You may change your MinGW Account Options or unsubscribe at:
https://lists.sourceforge.net/lists/listinfo/mingw-users

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
MinGW-users mailing list
[hidden email]

You may change your MinGW Account Options or unsubscribe at:
https://lists.sourceforge.net/lists/listinfo/mingw-users
Reply | Threaded
Open this post in threaded view
|

Re: configure error with vim72

JonY-2
On 11/11/2008 18:08, Sun, Xiuxin wrote:
> Yeser, actually there is another error and I don't know how to get also.
> ------------
> checking for sys/ipc.h... no
> configure: error: Cannot find required header file sys/ipc.h; PDCurses cannot be configured
> ------------
>

Hi,
you should read the instructions for building PDCurses with MinGW.

There are Makefiles already made for MinGW, you don't need to run
configure. Just copy the headers and libraries to your MinGW install
directory once the build is done.

Please also avoid top posting next time, thanks.

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
MinGW-users mailing list
[hidden email]

You may change your MinGW Account Options or unsubscribe at:
https://lists.sourceforge.net/lists/listinfo/mingw-users
Reply | Threaded
Open this post in threaded view
|

Re: configure error with vim72

Soren Andersen
In reply to this post by Sun, Xiuxin
I'm responding to the message sent on 11 Nov 2008, at around 09:39
UTC, by "Sun, Xiuxin " <xiuxin.sun ~at~ OBSCURED dot NUL>, who wrote

> When I want to compile the latest vim, get following error in
> msys :
>
>  -------------
>  no terminal library found
>  checking for tgetent()... configure: error: NOT FOUND!
>        You need to install a terminal library; for example
>        ncurses. Or specify the name of the library with
>      --with-tlib.
>  -------------
>
> I think all based msys compile pkgs from MingW website are copyed,
> please sugguest what I can do.
Building a MSYS (*not* MinGW) Vim, Xiuxin?

Please try to provide full relevant information, preferably in
readable English, when asking a technical mailing list for advice.

   Cordially,
     Sören 'somian' Andersen

--
Blame it on Caradhras the Cruel.

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
MinGW-users mailing list
[hidden email]

You may change your MinGW Account Options or unsubscribe at:
https://lists.sourceforge.net/lists/listinfo/mingw-users
Reply | Threaded
Open this post in threaded view
|

Re: build error with vim72

Sun, Xiuxin

HI,
thanks for the reply. I am a new person in the list, sorry if I can't tell problems clearly, but I do need your help.
Yes, I have MingW&MSYS installed.
Now I also installed PDCurses successfully and can run configure on VIM, but when compiling it, have following errors:
---------------
vim.h:296:23: os_win32.h: No such file or directory
In file included from buffer.c:28:
vim.h:1583: error: syntax error before "proftime_T"
---------------

And from internet I get that it may not be possible for MingW to compile Linux source of vim. So I download the vim72rt.zip and vim72src.zip and go to vim/vim72/src to run make with Make_ming.mak. After compilation finished I thought that I made it, but vim.exe hangs when I try to run it on rxvt terminal.

thanks,
sun

-----Original Message-----
From: Soren Andersen [mailto:[hidden email]]
Sent: 2008年11月12日 0:01
To: [hidden email]
Subject: Re: [Mingw-users] configure error with vim72

I'm responding to the message sent on 11 Nov 2008, at around 09:39 UTC, OBSCURED dot NUL>, who wrote

> When I want to compile the latest vim, get following error in msys :
>
>  -------------
>  no terminal library found
>  checking for tgetent()... configure: error: NOT FOUND!
>        You need to install a terminal library; for example
>        ncurses. Or specify the name of the library with
>      --with-tlib.
>  -------------
>
> I think all based msys compile pkgs from MingW website are copyed,
> please sugguest what I can do.
Building a MSYS (*not* MinGW) Vim, Xiuxin?

Please try to provide full relevant information, preferably in readable English, when asking a technical mailing list for advice.

   Cordially,
     Sören 'somian' Andersen

--
Blame it on Caradhras the Cruel.

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge Build the coolest Linux based applications with Moblin SDK & win great prizes Grand prize is a trip for two to an Open Source event anywhere in the world http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
MinGW-users mailing list
[hidden email]

You may change your MinGW Account Options or unsubscribe at:
https://lists.sourceforge.net/lists/listinfo/mingw-users
-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
MinGW-users mailing list
[hidden email]

You may change your MinGW Account Options or unsubscribe at:
https://lists.sourceforge.net/lists/listinfo/mingw-users