MSVCR80 _fstat not found (even when using correct specs)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

MSVCR80 _fstat not found (even when using correct specs)

lkcl
i read up on this:
http://lists-archives.org/mingw-users/11873-fstat-and-msvcr-71-80-90.html

at the second attempt, i successfully got the specs files created as advised.

i've just re-encountered this _fstat issue.



an additional search shows this:

http://lua-users.org/lists/lua-l/2008-07/msg00309.html

ok - let's have a look at libmsvcr80.a

$ nm /mingw/lib/libmsvcr80.a | grep fstat
00000000 T __fstati64
00000000 I __imp___fstati64
00000000 T __fstat64
00000000 I __imp___fstat64
00000000 T __fstat
00000000 I __imp___fstat

oops.  there's an fstat, but no fstat32.  ok, what about moldnames80?

$ nm /mingw/lib/libmoldname80.a | grep fstat
00000000 I __imp__fstat
00000000 T _fstat

oops.


yaay, yippee, no 32-bit names!   and... mingw runs on... a 32-bit system.

strings on msvcr80.dll shows these:

_fstat32
_fstat32i64
_fstat64
_fstat64i32

anyone got any ideas?

l.

------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
MinGW-users mailing list
[hidden email]

You may change your MinGW Account Options or unsubscribe at:
https://lists.sourceforge.net/lists/listinfo/mingw-users

_______________________________________________
This list observes the Etiquette found at http://www.mingw.org/Mailing_Lists.
We ask that you be polite and do the same.
Reply | Threaded
Open this post in threaded view
|

Re: MSVCR80 _fstat not found (even when using correct specs)

Roumen Petrov
Luke Kenneth Casson Leighton wrote:

> i read up on this:
> http://lists-archives.org/mingw-users/11873-fstat-and-msvcr-71-80-90.html
>
> at the second attempt, i successfully got the specs files created as advised.
>
> i've just re-encountered this _fstat issue.
>
>
>
> an additional search shows this:
>
> http://lua-users.org/lists/lua-l/2008-07/msg00309.html
>
> ok - let's have a look at libmsvcr80.a
>
> $ nm /mingw/lib/libmsvcr80.a | grep fstat
> 00000000 T __fstati64
> 00000000 I __imp___fstati64
> 00000000 T __fstat64
> 00000000 I __imp___fstat64
> 00000000 T __fstat
> 00000000 I __imp___fstat
>
> oops.  there's an fstat, but no fstat32.  ok, what about moldnames80?
>
> $ nm /mingw/lib/libmoldname80.a | grep fstat
> 00000000 I __imp__fstat
> 00000000 T _fstat
>
> oops.
>
>
> yaay, yippee, no 32-bit names!   and... mingw runs on... a 32-bit system.
>
> strings on msvcr80.dll shows these:
>
> _fstat32
> _fstat32i64
> _fstat64
> _fstat64i32
>
> anyone got any ideas?
>
> l.


Pending issue at
https://sourceforge.net/tracker/?func=detail&aid=2134161&group_id=2435&atid=352435


Roumen


------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
MinGW-users mailing list
[hidden email]

You may change your MinGW Account Options or unsubscribe at:
https://lists.sourceforge.net/lists/listinfo/mingw-users

_______________________________________________
This list observes the Etiquette found at http://www.mingw.org/Mailing_Lists.
We ask that you be polite and do the same.